Skip to product information
1 of 7
✓ Save $10.00

TP-Link JetStream 48-Port Gigabit L2 Managed Switch with 4 SFP Slots TL-SG3452

SKU: SG3452

Regular price $569.99 CAD
Sale price $569.99 CAD Regular price $579.99 CAD
Sale Sold out
Shipping calculated at checkout.
Only 7 units left
  • 48× Gigabit RJ45 ports and 4× Gigabit SFP slots
  • Centralized cloud management via the web or the Omada app†
  • Standalone management via web, CLI, SNMP, and RMON
  • Static Routing helps route internal traffic for higher efficiency
  • VLAN, ACL, QoS, and IGMP Snooping
  • ERPS supports rapid protection and recovery in a ring topology
  • Fanless design for silent operation
  • Durable metal casing and rackmountable design
Download Datasheet

Payment methods

Payment methods
  • American Express
  • Apple Pay
  • Diners Club
  • Discover
  • Mastercard
  • PayPal
  • Shop Pay
  • Visa

  • Vendor:

    Tp-link

View Product Details
  • HARDWARE FEATURES: 48× Gigabit RJ45 Ports, 4× SFP Slots, RJ45 & Micro-USB Console, Fanless Design, Rack Mountable, Physical Lock, 100–240V Power, 34.86W Max Consumption, 118.94 BTU/h Heat
  • PERFORMANCE: 12Mbit Buffer, 9KB Jumbo Frame, 104Gbps Switching Capacity, 77.38Mpps Forwarding Rate, 16K MAC Table
  • QUALITY OF SERVICE: 8 Queues, 802.1p/DSCP Priority, SP/WRR Scheduling, Bandwidth Control, QoS Remarking
  • L2 & L2+ FEATURES: IPv4/IPv6 Interfaces, Static Routing, ARP Table, DHCP Server/Relay, Link Aggregation, STP, Loopback Detection, Flow Control, Port Mirroring, DLDP
  • L2 MULTICAST: IGMP/MLD Snooping, 511 Multicast Groups, IGMP Authentication, MVR, Multicast Filtering Profiles
  • ADVANCED FEATURES: Device Discovery, Batch Config & Firmware Upgrade, Network Monitoring, Event Alerts, Unified Config, Reboot Schedule
  • ISP FEATURES: L2PT, DLDP, PPPoE ID Insertion, ERPS
  • VLAN: 4K VLAN Groups, 802.1Q, MAC VLAN, Protocol VLAN, GVRP, QinQ, Voice VLAN
  • ACCESS CONTROL LIST: Time-based, MAC/IP/IPv6 ACL, Packet Filtering, QoS Policy, Port/VLAN Binding
  • SECURITY: IP-MAC Binding, DHCP Snooping, ARP Inspection, Source Guard, DoS Protection, Port Security, Storm Control, 802.1X, AAA, HTTPS/SSH Secure Access
  • IPv6: Dual Stack IPv4/IPv6, Static Routing, ND, ICMPv6, DHCPv6, IPv6 Applications Support
  • MIBs: RFC1213, RFC1493, RFC2674, Radius MIBs, RMON (1,2,3,9), TP-Link Private MIBs
  • MANAGEMENT FEATURES: Omada App, Cloud & Centralized Management, Zero-Touch Provisioning, CLI/Web GUI, SNMP v1/v2c/v3, LLDP, DHCP AutoInstall, Dual Image, Monitoring & Diagnostics
  • OTHERS: CE/FCC/RoHS Certified, Package (SG3452 Switch, Power Cord, Rack Kit), OS Support (Windows/macOS/Linux), Temp 0–40°C, Humidity 10–90%
No Data

FAQs : TP-Link TL-SG3452

The TP-Link TL-SG3452 is a JetStream L2 managed switch designed to provide reliable Gigabit connectivity and advanced network management for professional business environments.
The TL-SG3452 features 48 Gigabit Ethernet ports and 4 SFP slots, providing ample connectivity for network devices along with flexible fiber uplink options.
The four SFP slots allow compatible fiber connections, making it easier to create uplinks, extend network distances, and connect different parts of a business network.
Yes. Its high port density, managed switching capabilities, and fiber connectivity make it suitable for offices, enterprises, campuses, and other professional network deployments.